Firefox 2.0.0.13 corregidas 6 vulnerabilidades

27 03 2008

Hace nada más unos minutos me saltó el aviso del Secunia PSI(RC1) de que había algún programa no actualizado, me quedé algo extraño, porque no sabía cual era, entonces mientras abría una ventana al gmail del grupo me saltó la actualización del Firefox.

Busqué información sobre las vulnerabilidades que habían corregido esta vez, y me tope con un artículo de vsantivirus donde las nombraba.

Firefox

Mozilla ha publicado Firefox 2.0.0.13, el cuál corrige al menos 6 vulnerabilidades, dos de ellas críticas.

Una de las vulnerabilidades de impacto crítico, está descripta en el aviso de seguridad MFSA 2008-14. La actualización soluciona un fallo que permite la elevación de privilegios y la ejecución arbitraria de código, a partir de JavaScript. Afecta también a Thunderbird 2.0.0.12 y anteriores y SeaMonkey 1.1.8 y anteriores.

El aviso de seguridad MFSA 2008-15, está relacionado con un problema que hace que el navegador deje de responder, con evidencias de corrupción de memoria, lo que podría ser utilizado para la ejecución arbitraria de código. Afecta a Firefox, Thunderbird y SeaMonkey.

Como moderada está catalogada una vulnerabilidad causada por un problema en la interpretación del valor HTTP Referer, un componente del protocolo HTTP que se encuentra en la cabecera de la operación GET que es enviada por los navegadores al servidor. El fallo puede ser utilizado para un ataque a sitios web, y está descrito en el aviso de seguridad MFSA 2008-16.

Un problema relacionado con la autenticación SSL del navegador y catalogado como de bajo impacto (MFSA 2008-17), puede convertirse en un potencial riesgo para la privacidad del usuario. Ésta vulnerabilidad, como la anterior, afecta a Firefox (2.0.0.12 y anteriores) y SeaMonkey (1.1.18 y anteriores).

De impacto alto es la vulnerabilidad descripta en MFSA 2008-18. La versión 2.0.0.13 de Firefox corrige un problema con Java, que permite la apertura de puertos arbitrarios en el equipo del usuario, lo que habilita conexiones no deseadas a través de LiveConnect. Afecta también a SeaMonkey.

Por último, el aviso MFSA 2008-19, también de impacto alto, describe una vulnerabilidad con XUL (eXtensible User-Interface Language), que permite crear ventanas emergentes que cubran elementos activos de una página web (por ejemplo una ventana que pida usuario y contraseña). Eso facilita acciones de spoofing y phishing.

XUL es un lenguaje desarrollado por Mozilla y Netscape a partir de una serie de marcadores XML que permiten el intercambio de datos de la interfaz de usuario. Son afectados Firefox y SeaMonkey.

Firefox 2.0.0.13 que corrige estas vulnerabilidades, está disponible para descarga manual, o a través de la actualización automática (se requieren privilegios administrativos).

Última versión NO vulnerable:

– Firefox 2.0.0.13

Referencias:

MFSA 2008-14 JavaScript privilege escalation and arbitrary code execution
http://www.mozilla.org/security/announce/2008/mfsa2008-14.html

MFSA 2008-15 Crashes with evidence of memory corruption (rv:1.8.1.13)
http://www.mozilla.org/security/announce/2008/mfsa2008-15.html

MFSA 2008-16 HTTP Referrer spoofing with malformed URLs
http://www.mozilla.org/security/announce/2008/mfsa2008-16.html

MFSA 2008-17 Privacy issue with SSL Client Authentication
http://www.mozilla.org/security/announce/2008/mfsa2008-17.html

MFSA 2008-18 Java socket connection to any local port via LiveConnect
http://www.mozilla.org/security/announce/2008/mfsa2008-18.html

MFSA 2008-19 XUL popup spoofing variant (cross-tab popups)
http://www.mozilla.org/security/announce/2008/mfsa2008-19.html

Más información:

Known Vulnerabilities in Mozilla Products
http://www.mozilla.org/projects/security/known-vulnerabilities.html

Mozilla.org Security Center
http://www.mozilla.org/security/

Vía: vsantivirus


Acciones

Information

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s




A %d blogueros les gusta esto: